Merge pull request #1689 from g199209/master

Add CMake minimum version required.